【wordpress 3.9】ビジュアルエディタが使えない不具合の原因は PS Disable Auto Formattingでした。

0
883
wordpress 3.9】ビジュアルエディタが使えない不具合の原因は PS Disable Auto Formatting
Pocket

wordpress が久々にメジャーアップデートし、【wordpress 3.9】にバージョンアップしました。

今までのメジャーアップデートではそれほど大きな不具合が無かったので油断していたのですが、今回【wordpress 3.9】にアップデートしてから、何故か【テキストエディタ】しか使えず、【ビジュアルエディタ】が使用できない・切り替えできない状態に。まあ記事が書けないこともないんですが、やっぱり直したいですよね。

という事で、なんとか【wordpress 3.9】において、ビジュアルエディタが使えない不具合の原因を究明し、解決できたので、そのご報告を。ちなみに管理人の環境での原因は【 PS Disable Auto Formatting 】でした。

【wordpress 3.9】ビジュアルエディタが使えない不具合の原因は PS Disable Auto Formatting

ネットで調べると、すぐに解決策は判明。

もちろん、環境によっては別の原因もあるかもですが、管理人の環境【wordpress 3.9】においてビジュアルエディタが使えない不具合の原因は【 PS Disable Auto Formatting 】でした。

※TinyMCE Advancedが原因の場合もあるようです。対策は「WordPressビジュアルエディタが切り替えできない表示されない|inoue2222.com」さんが詳しくご紹介されているので、自分は割愛します。

【 PS Disable Auto Formatting 】をアップデートする

【wordpress 3.9】ビジュアルエディタが使えない不具合の原因は【 PS Disable Auto Formatting 】だと判明したのですが、現時点ではまだ公式改良版がリリースされていません。本来ならアップデート・修正版がリリースされるまで【テキストエディタ】を使うか、【 PS Disable Auto Formatting 】を停止するかのどちらかで対応しないといけませんが、今回は裏ワザ的に、非公式改良版をインストールして解決してみました。

WORDPRESS 日本語フォーラムにて、有志の方が改良・修正版の【 PS Disable Auto Formatting 】をアップして下さっていますので、これをありがたく使用させてもらいました。※自己責任でご利用くださいね。

・PS Disable Auto Formatting v1.0.8とWP3.9 |WORDPRESS 日本語フォーラム

上記サイトから、【 PS Disable Auto Formatting 】をダウンロード。通常ならzipをそのままアップロードすればいいんですけど、試すと致命的なエラーと表示され更新できず。

そのため、

1.一度【プラグイン】→【 PS Disable Auto Formatting 】を停止。

2.ダウンロードした【 PS Disable Auto Formatting 】を解凍。事前にローカルに保存してあった改良前の【 PS Disable Auto Formatting 】をバックアップし、改良版の【 PS Disable Auto Formatting 】を現在のフォルダに上書き更新。それをFFFTPを使ってアップロードして更新。

3.再度【 PS Disable Auto Formatting 】を有効化

この手順で問題なく上書き更新ができ、ビジュアルエディタも使用できるようになりました。もしかすると、プラグイン停止→改良版【 PS Disable Auto Formatting 】zipをアップロードでも可能かもしれませんが、管理人は試していません。

以上、参考になれば幸いです。

Pocket

- Advertisement -

NO COMMENTS

質問やご感想があればお気軽にどうぞ。コメントは管理人の承認後に表示されます。※メアドは非公開です。